
 

 

Bangladesh Forest Department 
20 – 21 September 2016 



1 | Q G I S  B A S I C  T U T O R I A L

The UN-REDD Programme, implemented by FAO, UNDP and UNEP, has two components: (i) 
assisting in developing countries to prepare and implement national REDD strategies and 
mechanisms; (ii) supporting the development of normative solutions and standardized 
approaches based on sound science for a REDD instrument linked with the UNFCCC. The 
programme helps empower countries to manage their REDD processes and will facilitate access 
to financial and technical assistance tailored to the specific needs of the countries. 

The application of UNDP, UNEP and FAO rights-based and participatory approaches will also help 
ensure the rights of indigenous and forest-dwelling people are protected and the active 
involvement of local communities and relevant stakeholders and institutions in the design and 
implementation of REDD plans. 

The programme is implemented through the UN Joint Programmes modalities, enabling rapid 
initiation of programme implementation and channelling of funds for REDD efforts, building on 
the in-country presence of UN agencies as a crucial support structure for countries. The UN-REDD 
Programme encourage coordinated and collaborative UN support to countries, thus maximizing 
efficiencies and effectiveness of the organizations’ collective input, consistent with the “One UN” 
approach advocated by UN members. 

The UN-REDD Bangladesh National Program is implemented by the Bangladesh Forest 
Department under the leadership of Ministry of Environment and Forests. United Nations 
Development Program (UNDP) and Food and Agriculture Organization (FAO) are the two 
implementing partners. 

Contacts 

Rakibul Hassan Mukul 
Project Director  
UN-REDD Bangladesh National Programme 
Bangladesh Forest Department  
Email: pd-unredd@bforest.gov.bd  

Matieu Henry  
Chief Technical Advisor 
Food & Agriculture Organization of the United Nations 
Email: matieu.henry@fao.org  

Suggested Citation: Costello, L., Akhter, M. & Hoque, A. 2016. First Training Material on Basic Quantum 
Geographic Information System (QGIS). 20-21 September 2016, Dhaka, Bangladesh Forest Department, 
Food and Agriculture Organization of the United Nations.  

Disclaimer 

This report is designed to reflect the activities and progress related to UNJP/BGD/057/UNJ UN-REDD 

Bangladesh National Programme. It does not reflect the official position of the supporting international 

agencies including FAO and UNDP and should not be used for official purposes. Should readers find any 

errors in the document or would like to provide comments for improving the quality they are encouraged 

to contact one of above contacts.   

mailto:matieu.henry@fao.org
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EXECUTIVE SUMMARY 

The training will follow a structured and sequential method on the basis of the needs and the training 

methodology will be fully interactive and hands on which will have advantages like:  

 Hands-on training methods are effective for training in new procedures and new equipment.
 They are immediately applicable to trainees’ jobs.
 They allow trainers to immediately determine whether a trainee has learned the new skill or

procedure.

To import GPS data from a file that is not a GPX file, you use the tool Import other file in the GPS Tools 
dialog. Here you select the file that you want to import (and the file type), which feature type you want 
to import from it, where you want to store the converted GPX file and what the name of the new layer 
should be. Note that not all GPS data formats will support all three feature types, so for many formats 
you will only be able to choose between one or two types. Total 21 participants (16 male and 5 
female) attended the training. 
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1. BACKGROUND 

The first national forest inventory for Bangladesh was implemented in the year 2005 with the support 

from FAO. The inventory was conducted using a systematic sampling design, based on measurement of 

299 plots distributed across the entire country. Based on the existing national forest assessment data and 

additional accessible field inventory and model data, the aim of this training is to provide support on data 

management and analysis, quality control and assurance.  

QGIS (previously known as Quantum GIS) is a community driven free and open-source desktop geographic 

information system (GIS) application that provides data viewing, editing, and analysis. Similar to other 

software GIS systems, QGIS allows users to create maps with many layers using different map projections. 

Maps can be assembled in different formats and for different uses. QGIS allows maps to be composed 

of raster or vector layers. Different kinds of raster images are supported, and the software 

can georeference images. QGIS has a small file size compared to commercial GIS's and requires 

less RAM and processing power; hence it can be used on older hardware or running simultaneously with 

other applications where CPU power may be limited. QGIS supports dxf, shapefiles, coverages, and 

personal geodatabases. MapInfo, PostGIS, and a number of other formats. Web services, including Web 

Map Service and Web Feature Service, are also supported to allow use of data from external sources.  

A number of public and private organizations have adopted QGIS. Innovative use of QGIS plugins such as 

Open Street Map (OSM) may also provide efficiencies for the inventory process. OSM’s functionality that 

provides geo-referenced printed maps that can be marked in the field and then uploaded and digitised 

may be useful for monumenting permanent sample inventory plots and assist in the archiving process.  

Objective 

 Identify baseline capacity of GIS capacity external to RIMS 

 Increase sustainability of GIS capacity at FD by targeting participants outside of RIMS 

 Increase capacity on basic GIS operations 

Proposed Methodology  

The training will follow a structured and sequential method on the basis of the needs and the training 

methodology will be fully interactive and hands on which will have advantages like:  

 Hands-on training methods are effective for training in new procedures and new equipment. 
 They are immediately applicable to trainees’ jobs. 
 They allow trainers to immediately determine whether a trainee has learned the new skill or 

procedure.  
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2. GETTING ACQUAINTED WITH GIS 

2.1. WHAT'S GIS 

The acronym GIS refers to Geographic Information Systems - a tool that allows geographers and analysts 

to visualize data in several different ways in order to see patterns and relationships in a given area or 

subject. These patterns generally appear on maps but they can also be found on globes or in reports and 

charts. GIS is a computer based tools for mapping and analyzing features and events on earth. GIS 

technology integrates common database operations such as query and statistical analysis with the unique 

visualization and geographic analysis benefits offered by maps. 

 

In a GIS, you connect data with geography. You understand what belongs where. Because you don’t fully 

understand your data until you see how it relates to other things. 

 

It’s REALLY hard to visualize the locations of latitudes and longitudes coordinates from a spreadsheet. 

 

 

 

 

 

Attribute table 

But when you add these positions on a map, it’s like magic to the reader. 

 

 

 

 

 

 

 

Latitude and Longitude on a Map 

Everyone knows that maps make geographic information easier to understand. However, at present, 

maps are not only confined to help visualize some complex or boring charts rather it has more profound 

influence and benefits to almost every sector of our life. 

 

2.2 Usefulness of GIS 

GIS is a very powerful decision-making tool that has a massive range of applications, whatever your 

business – resource management, logistics, planning, transport, surveying, demographic studies, 

epidemiology and environment, to name but a few. 

With GIS, you can analyse topographic, environmental, demographic and land use data to help you with 
your business decisions and project management. 
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Uses of GIS range from indigenous people, communities, research institutions, environmental scientists, 
health organisations, land use planners, businesses, and government agencies at all levels. Some examples 
include: 

 Resource mapping 

 Hydrological Analysis 

 Remote sensing applications 

 Public Participation GIS 

 Road networking 

 Rout planning 

 Wastewater and storm water systems 

 Waste management 
 

2.3 A Short History of GIS 
The first truly operational GIS appeared in Ottawa, Ontario in 1962 and was developed by Roger 
Tomlinson of Canada's Department of Forestry and Rural Development in an effort to use map overlays 
for analysis of various areas in Canada. This early version was called CGIS. 
  

The more modern version of GIS used today emerged in the 1980s when ESRI (Environmental Systems 
Research Institute) and CARIS (Computer Aided Resource Information System) created a commercial 
version of the software that incorporated the methods of CGIS, but also included newer "second 
generation" techniques. Since then it has undergone a number of technological updates, making it an 
efficient mapping and informational tool. 
 

With the acknowledgement of the importance of data and its power, gradually people have learnt the 
necessity to open GIS for general people without the complications of licensing and purchasing the GIS 
software and with this view, emerges the concept of QGIS in 2002. 
 

2.4 QGIS: What and Why? 
QGIS acronym refers to Quantum GIS is a cross-platform free and open-source desktop geographic 
information system (GIS) application that provides data viewing, editing, and analysis. Similar to other 
software GIS systems, QGIS allows users to create maps with many layers using different map 
projections. Maps can be assembled in different formats and for different uses. QGIS allows maps to be 
composed of raster or vector layers. Typical for this kind of software, the vector data is stored as either 
point, line, or polygon-feature. Different kinds of raster images are supported, and the software can 
georeference images. 
 

Here are five strong reasons why QGIS offers as a much acceptable option in field of GIS: 
 
QGIS is Free 
QGIS is FOSS which stands for Free and Open Source Software. Anybody with an Internet connection 
can visit one of the download sites and retrieve a copy of the GIS software. There is no cost the to user 
and the source code is available under the terms of the GNU General Public License(GPL).  Downloading 
the software only cost to you your time. 
 
 

https://en.wikipedia.org/wiki/Georeferencing
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QGIS is Cross Platform 
On a Mac, PC, or Linux machine? It doesn’t matter. There is a QGIS installation package available for all 
three operating systems. There is also a build for Android for those users wanting to get QGIS up and 
running on a compatible tablet. Unfortunately, the licensing policy for iOS and therefore its incompatibility 
with GPL means no iPad versions will be available anytime soon. The cross platform availability of QGIS 
opens it up to a wider range of potential users than many of the commercial versions currently on the 
market. QGIS’ growing popularity can, in part, be attributed to the lack of comprehensive Mac-based GIS 
software applications. For Mac users who don’t want to have to run a PC only GIS software application on 
a virtual machine, QGIS is becoming a very acceptable alternative. 
 

The Use of Open Source GIS is Growing 
While it certainly hasn’t reached the widespread level of Esri’s ArcGIS platform, QGIS is growing in its use 
as a viable alternative to commercial GIS. The QGIS organization publishes case studies that highlight the 
practical application of the GIS software on its site which includes the decision by the Swiss Canton of 
Solothurn to use QGIS instead of Esri products in 2006 to fulfill the geospatial needs involved in serving 
its 250,000 citizens. How many users of QGIS out there is hard to pinpoint but Gary Sherman, the founding 
developer of QGIS, performed some analysis on worldwide QGIS users by geocoding the I.P. addresses 
where QGIS was downloaded. From that analysis, Sherman estimated in December of 2011 that there 
were at least 100,000 users globally of Quantum GIS. 
 

Plenty of QGIS Support and Tutorials 
If you’re worried that you’ll be left on your own to slog through figuring out QGIS, know that QGIS has a 
thriving user based support. There is a growing and active volunteer developer base that works on fixing 
bugs and extending the functionality of QGIS. Nathan W. created an interesting video visualizing the 
growth of QGIS based on commit history logs. 
 

Peer support for issues about using QGIS can be answered by tagging questions with QGIS on the GIS 
Stack Exchange section. The QGIS site has a “How do I do that in QGIS?” with introductory tutorials 
covering working with raster and vector data, spatial analysis, and cartography. The Free and Open 
Source GIS Ramblings blog run by Anita Graser is an excellent source for QGIS tips and tutorials. 
 

The Getting Started with QGIS article has further pointers to resources for learning QGIS 

https://gislounge.com/getting-started-with-qgis-open-source-gis/
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2.5 QGIS Interface  
 

To launch QGIS, click: Start -> All Programs -> QGIS -> QGIS Desktop. QGIS normally adds the version 
number after “QGIS”, which is currently 2.16.2. The main windows of QGIS can be divided into three 
regions shown in Figure 1. 
 

 
Figure 1. The Main Window of QGIS showing Regions 

 
 
 
Frequently-used File Formats in QGIS: 
 

Feature Data: Feature data are usually organized as points, lines, and polygons in vector format.



Shapefile: The most commonly used geospatial data format. Although it appears to be one file in ArcMap, 
shapefile includes multiple files with the same file name, but different extensions. *.shp, *,dbf, and *.shx 
are must-have.



Personal Geodatabase: These files are based on Microsoft Access (*.mdb). From user perspective, 
all kinds of geodatabase are the same, which include multiple layers (different geospatial data) in 
one geodatabase.



MapInfo files: The following three are legendary geospatial file formats. MapInfo is the first desktop 
GIS software for Windows. Its files (*.tab) are widely used.



ArcInfo: ArcInfo is the previous generation of ArcGIS. Its file (*.e00) are supported in QGIS as well.
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Google Earth: *.kml and *.kmz (zipped KML) are Google Earth file formats, which are popular in Location-
Based Service now. Many websites support kml and kmz files.



GML and GeoJSON: Open source geospatial data standard, which is also popular in online 
applications.



GPS: The track of GPS records can be imported into QGIS as *.gpx files. This function is very useful 
in surveying.



CSV: *.csv files stands for comma separated value, which can be regarded as a legendary 
spreadsheet file format.



Raster Data: Raster data uses grid to represent a region with values as a “field”. Images explicitly 
have the parameter of resolution. Typical raster data is:



GeoTIFF: They have the file extension of *.tif. The key difference between normal TIFF file and GeoTIFF is 
that GeoTIFF has projection information. Hence, normal TIFF files cannot be correctly added to the 
desired location.



GeoJPEG: Similar to GeoTIFF, but they have *.jpg extension.



Usage: Raster data can be air photos, satellite images, elevation data (DEM). But raster data tends to 
be huge and slow to load.
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3. LOADING AND INTEGRATING DIFFERENT FORMATS OF DATA WITH QGIS 
3.1. GPS to QGIS 
 

There are dozens of different file formats for storing GPS data. The format that QGIS uses is called GPX 
(GPS eXchange format), which is a standard interchange format that can contain any number of 
waypoints, routes and tracks in the same file. 

To load a GPX file you first need to load the plugin. Plugins ‣  Plugin Manager... opens the Plugin 
 

Manager Dialog. Activate the  GPS Tools checkbox. When this plugin is loaded two buttons with a 
small handheld GPS device will show up in the toolbar: 

 


 

 



Create new GPX Layer 

 

 
GPS Tools 

For working with GPS data we provide an example GPX file using which the following steps 
have to be performed- 

1. Select Vector ‣ GPS ‣ GPS Tools or click the  GPS Tools icon in the toolbar and open the 

Load GPX file tab (see figure_GPS_1). 
 

2. Browse to the folder qgis_sample_data/gps/, select the GPX file national_monuments.gpx and 
click [Open]. 

 

Figure GPS 1: 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

                                                     The GPS Tools dialog window 

http://docs.qgis.org/2.0/en/docs/user_manual/working_with_gps/plugins_gps.html#figure-gps-1
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Use the [Browse...] button to select the GPX file, then use the checkboxes to select the feature types 
you want to load from that GPX file. Each feature type will be loaded in a separate layer when you 
click [OK]. The file national_monuments.gpx only includes waypoints. 
 

Note 
GPS units allow to store data in different coordinate systems. When downloading a GPX file (from your 
GPS unit or a web site) and then loading it in QGIS, be sure that the data stored in the GPX file uses 
WGS84 (latitude/longitude). QGIS expects this and it is the official GPX specification. 
 

GPSBabel 
Since QGIS uses GPX files you need a way to convert other GPS file formats to GPX. This can be done for 
many formats using the free program GPSBabel, which is available at http://www.gpsbabel.org. This 
program can also transfer GPS data between your computer and a GPS device. QGIS uses GPSBabel to 
do these things, so it is recommended that you install it. However, if you just want to load GPS data from 
GPX files you will not need it. Version 1.2.3 of GPSBabel is known to work with QGIS, but you should be 
able to use later versions without any problems. 
 

Importing GPS data 
To import GPS data from a file that is not a GPX file, you use the tool Import other file in the GPS Tools 
dialog. Here you select the file that you want to import (and the file type), which feature type you want 
to import from it, where you want to store the converted GPX file and what the name of the new layer 
should be. Note that not all GPS data formats will support all three feature types, so for many formats 
you will only be able to choose between one or two types. 
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3.2. Loading Vector data (shapefile) 

Click the Add Vector Layer  button to add geospatial data (Figure 2), which opens a window (Figure 
3) 
 

 

 

 

 

 

 

  

Add data 
 

 

 

 

 

 

 

 

 
 
 
 
Figure 2. The Main Window : Add Vector Layer button Figure 3. The Pop-up Window to "Add Vector Layer" 

 

Then you can browse to the file you want to work with by clicking the Browse button just like any other 
file explorer dialogs in Windows. You can open multiple files at one time by holding the Ctrl or Shift 
button when you are clicking the mouse button to make selections. The by-default file filter is *.shp file 
(Figure 4). But there are many other choices, such as *.kml (Google Earth) and *.csv, much broader than 
ArcGIS. 
 

 

 

 

 

 

 

 

 

 

 

 

 

                                                      Figure 4. The File Open Dialog with File Filters 
 
For example, you can browse Khulna_Div.shp file from pov_khl folder that was provided in Practice Data 

folder as your sample dataset. 
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3.3. Load Google Maps ,Bing Maps and OpenStreetMaps : 
QGIS provides the flexibility of using Google (or Yahoo) Satellite images or Bing aerial images as a 
background layer in your map. To do so, follow the steps below: 
 

1. Install the OpenLayers Plugin into QGIS: 
a. Go to Plugins -> Manage and Install Plugins, which leads to a dialog. 
b. Type 'Openlayers Plugin' in the search box 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

c. Click on 'Install plugin' and the 'Openlayers Plugin' will be installed in your QGIS. 
 

2. Add Google Satellite map as Background layer: 
 

Go to the menu Web -> Openlayers plugin ->Add Google Satellite MAp. 
 

 

 

 

 

 

 

 

 

 

 

 

3. Add Bing Aerial Map as Background layer: 
Go to the menu Web -> Openlayers plugin -> Bing maps-> Bing aerial. 
 

4. Add Openstreet  Map as Background layer: 
Go to the menu Web -> Openlayers plugin -> OpenstreetMap-> OpenStreetMap 

 



14 | Q G I S  B A S I C  T U T O R I A L  
 

 

3.4 Creating KML layer in Google Map and Loading in QGIS: 
Google map or Google Earth makes use of KML or keyhole markup language, to display features, which 
actually stores geographic features in Vector format. You can create KML file from Google map for 
mapping and displaying the same by again uploading the same KML file on Google map or created KML 
file converted from Shapefile. Before creating KML file on Google map, you should have an Google 
account and should be logged in with that. So that once KML file created, you would be able to see it in 
My Places of Google map after wards. You can also look link for how to create KML file from Google earth. 
Steps are following: 
 

 Open Google map and sign in with all in one Google account. 

 Click on Menu ( Left corner of search option)> Your Places > Maps > Create Map ( At the 
Bottom) ( A new window will open) 

 Click on Add layer ( A new untitled layer will open)> Layer Option ( At the right corner with 
three dots) . You can rename , delete or see the table of the layer. 

            
 

Figure 5: Layer Option                                         Figure 6: The Drawing Options 
  

 In the map window  there are some drawing options. If you keep you cursor on the options, it 
will show you the name. Add marker is used only to put any points on map and Add line or 
shape is used for drawing any polygon or line .Before drawing , search your area in search 
options. 

Note that while you are drawing any polygon, it will be a confined area  and the starting and ending point 
will be the same. While drawing any feature, please complete your desired drawing  with double click at 
ending point. 

 

 When you have completed drawing any feature( point, line or polygon), a pop-up window will 
open to write the name and description about it and you will also find the edit and style options 
below he pop-up window. 
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Figure 7: The pop-up window for feature details 

 If you have completed drawing all the features under a layer , now it’s time to export the layer 
as KML. From Untitled map at left top corner of the page, there are three dots as representing 
different options. Click on it and select Export To KML. A pop-up window will open and select 
the desired layer and download it. The layer has been saved as KML file . 
 

  
Figure8 : Pop-up window of Export to KML 

 

 Open QGIS desktop > Add Vector layer > Browse kml layer> Right click  on kml layer > save it 
as  a shapefile from Save as option 

 
Figure 9: A pop-up window of save vector layer as option 
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3.5 Loading CSV File from excel and Modification of attribute table 
A CSV is a comma separated values file, which allows data to be saved in a table structured format. CSV 
can be converted from an excel file and it  is more necessary when we are using the date in QGIS. QGIS 
directly supports CSV file rather than an excel file. So, if you have an excel data to join, you must convert 
it into CSV file and then load into QGIS. 
 
Conversion to CSV 

 Open the Excel file in Microsoft Office Excel and save it as a anew file 
 Click on File> Save As> Select CSV as Save as type> Save 

 

 
Figure 10: Pop-up window of Excel Save as type option 

 
 
Loading CSV in QGIS 
Now, the excel file has been converted into a CSV file and will be loaded into QGIS. Click on Layer on 
menubar > Add Layer> Add Delimited Text Layer. The point to be noted that there are two types of 
tabular data: one contains geographic data (x, y coordinates) and another contains descriptive data 
having in details information. 
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Figure 11: Pop-up window showing to Layer option 

 
In case of geographic data, the file format will be CSV and geometry definition will be Point coordinates 
which will create a point layer in layer panel. Then you must save your layer as shapefile from Save as 
option by right clicking on the layer. 

 

  
Figure 12: CSV browsing in case of geographic data 

 
In case of descriptive data, file format will remain same as CSV but there be NO geometry in Geometry 
definition option but one thing to note down that this time data won’t create any shapefile unlike 
geographic data as it is a descriptive file having no geometric points. 
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Figure 13: CSV browsing in case of descriptive data 

 
 

3.6 Joining attribute table 
If we have both geographic and descriptive data both for any specific location, we will generate a point 
shapefile from GPS data and there must be some common attributes like Serial number in both file on 
basis we can join both data. As the point layer is a shapefile , it’s attribute table will expand after joining 
the description of the points. Besides, we can also join any tabular data with any shapefile with a 
condition of common coloumns in both .Steps are following: 

 Right click on shapefile> Properties > Joins 

 Click on plus sign (+)  at the left bottom to add the the table 

 Join layer will be the tabular descriptive data 

 Join Field and  Target field are the ncommon attributes we need to select 

 Click on Choose which fields are joined and  selecte the attributes according to 
requirements 

 Then Ok > in next window Apply>  Ok. 
 

Now Open the attribute table of shapefile by right clicking and you will see the added columnsin layer. 
But now,if we remove this layer now and then browse again you won’t find the added field anymore as 
it wasn’t saved when u added. So, whenever you are joining any data , just save it as another shapefile 
from Save as  option and after that as much as you remove , you will find the the data u added as same. 
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Figure 14: Pop-up window showing the join options 
 
 

Editing in attribute table 
As data input is very very manual, so it’s not ever surprising  if we find any typing mistake in attribute 
table . Then we need to make it correct or change anywhere if needed to use a correct data and from this 
point of view ,editing is one of the most important part in attribute table modification. To edit , open the 
attribute table of the layer  and click on the very first option , Toggle editing modein toolbar.Now the 
editing mode is active and you can delete or change any text or number or calculate any field or create 
any new field or add any new feature . 
 

 
 
 

Extracting selected attributes from table 
While we are having  huge dataset like any divisional map or any soil/forest  map for a large area or any 
distric map etc. having in detailed information and we want to work on a specific area or any specific 
attributes, we need to extract the data from the large dataset . The selection depends on the attributes 
we want to make an anlysis over. 
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 Open the attribute  table  and click on Select/ filter feature using from ( The view will be 
changed) 

 Then Coloumn preview > select the coloumn in which desired attributes are existing 

 Click on the attributes by pressing shift button you want to extract at left side ( The selected 
attributes will also be selected in map canvas) 

 Now right click on layer and save it as a new shapefile from Save as option. Now the new 
shapefile contains the selected attributes only. 

 

 
Figure 15: Pop-up window showing the select by attributes option 

 
Extracting attribute table as an excel file 

 Install the XY Tools into QGIS: 

 Go to Plugins -> Manage and Install Plugins, which leads to a dialog. 

 Type in the search box 

 Click on 'Install plugin' and the XyTools will be installed in your QGIS 

 Select the layer in layer panel first and then click on Vector > XY Tools> Save Attribute table as 
an excel file 

 Select the required fields and click on ok.  
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Figure 16: XY Tools option                                                                          Figure 17: save as Excel option 

 
3.7 Loading GPX File from excel and Using field calculator 
  
GPX stands for GPS exchange Format that c 

 Click on ADD Vector layer > Browse GPX file format using data type keeping GPX 

 Select  all the Layer 

 
Figure 18: GPX Data Format 

 

 Open Attribute table to check the data it contains. Waypoints , trackpoints have poins in 
shapefile. Now we will calculate X and Y coordinates using Field calculator. 
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Figure 19: Pop-up window of Vector layer to add 

 

 The point layer we want to add X and Y coordinates , need to open it’s attribute table 

 Click on Open fIeld calculator 
 

 
 

 Type field name , Field type, field length, precission and expression and Click on ok 
 

Note that we are calculating latitude select $y and double click on it to activate and while calculating 
longitude select $X and double click on it. The field type will be decimel degree as it is coordinate. 
 

 
Figure 20:Pop-up window of Field calculator 
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4. CREATE MAP 
4.1 Key Options of Geospatial Data Representations 
Main options of changing geospatial data representations include layer order, layer transparency, 
symbology, label, and annotation. Apart from the first one (layer order) and last one (annotations), all 
the rest are located in the pop-up window (Figure 21) when you right-click the layer you want to modify 
and select property (Figure 21). They are under either the style or labels tab. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure21. The Pop-up Window of a Layer's Property and the Property Window 
 

 

All options will be introduced as subsections in the following. 
 

4.1.1. Layer Order and Transparency 
 

QGIS displays geospatial data according to the order in the table of contents: the bottom layer will be 
drawn on the screen first and covered by upper layer. Hence, the layer on the top in the table of 
contents will be displayed as the top layer in the map. Unlike ArcMap, QGIS will not order layers 
automatically. 
 

When a feature layer (point, line or polygon) is put under a polygon-feature layer, the feature one is 
covered and invisible. You can change layer visibility by switching the checkboxes left to the layer name 
in table of contents (Figure 23). And the display order can be changed by simply dragging the layer 
toward or away from the top. 
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Figure 23 . Layer Visibility and Order Control 

 

When a polygon layer, such as buildings or parcels, is added over an image, the content on image under 
the building is often invisible. But sometimes users like to only show the parcel’s boundary and keep the 
image displayed. In this case, layer transparency and hollow symbology can help. To do so, right-click on 
the polygon layer and select Properties first (Figure 8). Then switch to the tab Symbology and click on the 
symbol itself (Figure 24). You can make polygons hollow by changing Fill options from solid to none. 
Alternatively, you can change the Transparency ratio as well. 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 24: Properties of Style 
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4.1.2. Symbology and Label 
 

Symbology or Style is critical in making maps, which are classified into four Legend type in QGIS (on the 
top of Figure). Due to its complexity, these four categories and their normal usages will be briefly 
introduced in the note region with further reading. We will only focus on symbol customization and 
classification symbols, which are mostly used. Unlike ArcMap, QGIS does not hold a large library of 
professional symbols. In fact, only point-feature layers can have different symbols (Figure 25), while line 
and polygon layers can only change line and fill options. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 25: The Symbology or Style Customization Window 
 

We can also categorized data depending on the categories in the Style option of Properties of a selected 
feature. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 26: Categorization in Style option 
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Note that you can still customize individual symbols for each category (size, shape, etc) by double clicking 
the corresponding class on either the left pane or the line in Style window (Figure). The labels are an 
important feature of a map.  
By marking some property up on the map, for instance the name of the marked location, labels can make 
your map more useful, informative, and visually appealing. To add labels to your map, right-click on the 
layer that you want to add marks on and select Properties (Figure 27 & 28). Then follow the steps below: 
 

  
Figure 27: Example of Style 

 

Figure 28: Selecting Graduated properties 
 

1. Select the Labels tab and check on (off by default) “Display labels”. 
2. Choose the attribute you want to display on the map in the dropbox of Field Containing label 

(Figure 14). 
3. Change Font, so that it is clearly shown on the map. 
4. You can click on the Apply button to see the effect until it is satisfactory. Then click OK to save 

your setting and exit. 
5. (Optional) If you think the added labels are not distinct on the map background, you can 

make a buffer background around the texts.  
 

Graduated Map- To present variation of data within a region a graduated map can be developed by 
right clicking on the layer and select Properties-> Style-> then select the options as the picture below. 
The class interval and the class breaks can be customized by clicking on them. 

 
Labels : To show the labels on any feature on the map we have to follow the process like  right clicking 
on the layer and select Properties-> Labels-> then select the steps as the picture below (Figure 29 and 
30). You have to define the Label with by selecting the column in attribute table you want to show on 
the map.  
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Figure 29: Showing labels on the map  

 
 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 30: Graduated Map with labels 

 



 
 
 

4.2. Map/Print Composer 
 

When the geospatial data and its representations are satisfactory, you can add other map components in another 
window via Project-> New Print Composer (Figure 31). You can manage multiple composers via File - > Composer 
Title box will pop up. Entering the Title a new window will pop up. 

 
Figure 31: New Print Composer in Project menu 

 

Key components of publishing a map include: 
 

 The title of the map;

 The scale of the map;

 The North Arrow (Orientation);

 The Legend (how to interpret the map);

 (Optional) The reference (where you obtain the data)

 Date of preparation and map preparing authority
 

 
 

Figure 32: Map Composer 



The main part, map, can be added by clicking in Layout>Add Map, and then drag a rectangle on the paper to define 
display area and extent. 
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Map titles can be added as a text box by clicking and then click on the spot where you want to place the title at. 
Please note that, in print composer, you can customize the properties of all components by switching to the ITEM tab. 
So, for instance, if you want to change the font of the title, click the title first (so that it is selected) and change to the 
ITEM tab. There is a button called Font where you can find all properties there.  
 
Add scale bar is also intuitive: click on and then click where you want to add it. You can change Unit label and Style. 
The scale bar style can be numeric, i.e. 1:5,000,000, or different bar/line forms. All options are intuitive and can be 
tested by changing it back and forth.  
 
North Arrow can be added as an arrow. The options of a north arrow in QGIS are very limited. Legend can be added 
in the same way as others (click on ).  
 
QGIS has better organization of legend properties than ArcMap. The major options are located under Legend items. 
You can fine tune in Item Options. 
 
Now we can start to assemble our map.  

 Go to Project ‣ New Print Composer. 

 You will be prompted to enter a title for the composer. You can leave it empty and click Ok. 
Note 
Leaving the composer name empty will assign a default name such as Composer 1. 
 
In the Print Composer window, click on Zoom full to display the full extent of the Layout. Now we would have to bring 
the map view that we see in the QGIS Canvas to the composer. You can add the items by choosing from Layer tab or 
the Layer Panel at left of the canvas (Figure 33).  
 

 Go to Layout ‣ Add Map 

 Once the Add Map button is active, hold the left mouse button and drag a rectangle where you want to 
insert the map.  

 
You will see that the rectangle window will be rendered with the map from the main QGIS canvas. The rendered map 
may not be covering the full extent of our interest area.  
 

 Select Layout ‣ Move item content to pan the map in the window and center it in the composer. 

 
 

Figure 33: Layer Tab and Layer Panel 
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 Let us adjust the zoom level for the given map. Click on the Item Properties tab and change the scale value 
adjusted the composer view as shown in figures below.  

 
 

 Now we will add a map inset that shows a zoomed in view for the Tokyo area. Before we make any changes 
to the layers in the main QGIS window, check the Lock layers for map item and Lock layer styles for map 
item boxes. This will ensure that if we turn off some layers or change their styles, this view will not change. 

 

 
 

 We can change the frame of the map using the Frame properties from Item Properties panel at right side 
9see the figure below .  

 

 
 
 



31 | Q G I S  B A S I C  T U T O R I A L  
 

 

 Now we will add a North Arrow to the map. The Print Composer comes with a nice collection of map-related 

images - including many types of North Arrows. Click Layout ‣ Add Image. 

 
 

 Holding your left mouse button, draw a rectangle on the top-right corner of the map canvas. On the right-
hand panel, click on the Item Properties tab and expand the Search directories section and select the North 
Arrow image of your liking as figure below 
 

 
 Now that we have the map inset ready, we will add a grid and zebra border to the main map. Select 

the Map 0 object from theItems panel. In the Item properties tab, scroll down to the Grids section. Click 
the Add a new grid button. 

 
Figure : To change the CSR 
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 By default, the grid lines use the same units and projections as the currently selected map projections. 
However, it is more common and useful to display grid lines in degrees. We can select a different CRS for the 
grid. Click on the change... button next to CRS. 
 

 In the Coordinate Reference System Selector dialog, enter 4326 in the Filter box. From the results, select 
the WGS84 EPSG:4326 as the CRS. Click OK. 

 
Figure: Add new grid 

 

 Select the Interval values as 5 degrees in both X and Y direction. You can adjust the Offset to change where 
the grid lines appear. 

 
 

 We can change the Gid frame style from Grid frame panel, size, thickness etc as below.  
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 It is time to label our map. Click on Layout ‣ Add Label. 

 Click on the map and draw a box where the label should be. In the Item Properties tab, expand 
the Label section and enter the text as shown below.  

 
 

 Click on the layout where you want the scalebar to appear. In the Item Properties tab, make sure you have 
chosen the correct map element for which to display the scalebar.  

 Choose the Style that fit your requirement. In the Segments panel, you can adjust the number of segments 
and their size. 
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 Let’s add the legend of the map by clicking add legend from Layer Tab and place the legend by click 

and dragging of left button of your mouse where you wish to place. Legend will be shown as 

available in the main QGIS data view as you displayed.  

 

 
 
 

4.3. Export Maps 
When you are satisfied with everything on the map and are ready to deliver, you can export your map as images, PDF, 
SVG, or print a hard copy. All options are under the File menu. You can specify the directory and file name of the map 
in this dialog. But, most importantly, you need to choose an appropriate file format by clicking on the Save as type 
dropbox. The most frequent-used formats are JPEG and PDF. JPEG is a popular graphic file format, which is easy to be 
inserted into word as a graph, while PDF is best used for sharing. The printed copy of PDF will be identical regardless 
of your computer (and printer) environment. 

 
 

 

 

 

 

 



35 | Q G I S  B A S I C  T U T O R I A L  
 

 

 

 

APPENDIX 1 : LIST OF PARTICIPANTS 
 

Name Email  

Ajit Kumar Rudra ajitrudra@yahoo.co.uk 

Md. Mozaharul Islam mazhar.raj@gmail.com 

Shawkat Imran Arafat shawkat.imran.arafat@gmail.com 

Md. Anisur Rahman anisur.boi@gmail.com 

Md. Delowar Hossain delowarhossain84@yahoo.com 

Rokeya Begum rupa_zaman@yahoo.com 

K. M. Nazmul Islam nazmul@ifescu.ac.bd 

Anatoli Poultouchidou anatoli.poultouchidou@fao.org 

Abdullah-al-mamun almamun.0022@gmail.com 

Nikhil Chakma nikhil.chakma@fao.org 

Nandini Sarker nandini.sarker@fao.org 

Md. Saiful Islam Dewan saiful.forester.bforest@gmail.com 

Champa Rani Saha champasaha21@gmail.com 

Sharmin Akter sharmin_tithy@yahoo.com 

Abu Yousuf yusufnaabe96@gmail.com 

Rakibul Hasan Mukul lalpiprey@gmail.com 

Imran Ahmed imranforest@live.com 

Md. Shahir Kabir sheikhshah00@gmail.com 

Mohammad Sohal Rana md_rana7777@yahoo.com 

Khan Zarin Tasnim Zarin.khan@fao.org 

Ahasanul Hoque hoqe.ahasan@gmail  

 
 
 
  

mailto:ajitrudra@yahoo.co.uk
mailto:mazhar.raj@gmail.com
mailto:shawkat.imran.arafat@gmail.com
mailto:anisur.boi@gmail.com
mailto:delowarhossain84@yahoo.com
mailto:rupa_zaman@yahoo.com
mailto:nazmul@ifescu.ac.bd
mailto:anatoli.poultouchidou@fao.org
mailto:almamun.0022@gmail.com
mailto:nikhil.chakma@fao.org
mailto:nandini.sarker@fao.org
mailto:saiful.forester.bforest@gmail.com
mailto:champasaha21@gmail.com
mailto:sharmin_tithy@yahoo.com
mailto:yusufnaabe96@gmail.com
mailto:lalpiprey@gmail.com
mailto:imranforest@live.com
mailto:sheikhshah00@gmail.com
mailto:md_rana7777@yahoo.com
mailto:Zarin.khan@fao.org
mailto:hoqe.ahasan@gmail

