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 The UN-REDD Programme, implemented by FAO, UNDP and UNEP, has two components: (i) 

assisting in developing countries to prepare and implement national REDD strategies and 

mechanisms; (ii) supporting the development of normative solutions and standardized 

approaches based on sound science for a REDD instrument linked with the UNFCCC. The 

programme helps empower countries to manage their REDD processes and will facilitate access 

to financial and technical assistance tailored to the specific needs of the countries. 

The application of UNDP, UNEP and FAO rights-based and participatory approaches will also 

help ensure the rights of indigenous and forest-dwelling people are protected and the active 

involvement of local communities and relevant stakeholders and institutions in the design and 

implementation of REDD plans. 

The programme is implemented through the UN Joint Programmes modalities, enabling rapid 

initiation of programme implementation and channelling of funds for REDD efforts, building on 

the in-country presence of UN agencies as a crucial support structure for countries. The UN-

REDD Programme encourage coordinated and collaborative UN support to countries, thus 

maximizing efficiencies and effectiveness of the organizations’ collective input, consistent with 

the “One UN” approach advocated by UN members. 

The UN-REDD Bangladesh National Program is implemented by the Bangladesh Forest 

Department under the leadership of Ministry of Environment and Forests. United Nations 

Development Program (UNDP) and Food and Agriculture Organization (FAO) are the two 

implementing partners. 
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EXECUTIVE SUMMARY 

The training followed a structured and sequential method on the basis of the needs and the training 

methodology was fully interactive and hands on with the participation of 14 forest officers and RIMs 

officials.  

 Printed agenda was provided to all the participants and all were presented and discussed in
an easy, understandable manner.

 All the training sessions were interactive and the questions and difficulties were solved during
practice session.

 All the participants were evaluated to know their enhanced capacity through a subject
oriented test.

Total 20 participants (14 male and 6 female) attended the training. 
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1. Background 
The first national forest inventory for Bangladesh was implemented in the year 2005 with the support 

from FAO. The inventory was conducted using a systematic sampling design, based on measurement of 

299 plots distributed across the entire country. Based on the existing national forest assessment data 

and additional accessible field inventory and model data, the aim of this training is to provide support 

on data management and analysis, quality control and assurance.  

QGIS (previously known as Quantum GIS) is a community driven free and open-

source desktop geographic information system (GIS) application that provides data viewing, editing, 

and analysis. Similar to other software GIS systems, QGIS allows users to create maps with many layers 

using different map projections. Maps can be assembled in different formats and for different uses. 

QGIS allows maps to be composed of raster or vector layers. Different kinds of raster images are 

supported, and the software can georeference images. QGIS has a small file size compared to 

commercial GIS's and requires less RAM and processing power; hence it can be used on older hardware 

or running simultaneously with other applications where CPU power may be limited. QGIS 

supports dxf, shapefiles, coverages, and personal geodatabases. MapInfo, PostGIS, and a number of 

other formats. Web services, including Web Map Service and Web Feature Service, are also supported 

to allow use of data from external sources.  

A number of public and private organizations have adopted QGIS. Innovative use of QGIS plugins such 

as Open Street Map (OSM) may also provide efficiencies for the inventory process. OSM’s functionality 

that provides geo-referenced printed maps that can be marked in the field and then uploaded and 

digitised may be useful for monumenting permanent sample inventory plots and assist in the archiving 

process.  

Objective 

 Identify baseline capacity of GIS capacity external to RIMS 

 Increase sustainability of GIS capacity at FD by targeting participants outside of RIMS 

 Increase capacity on basic GIS operations 

Used Methodology  

The training followed a structured and sequential method on the basis of the needs and the training 

methodology was fully interactive and hands on with the participation of 14 forest officers and RIMs 

officials.  

 Printed agenda was provided to all the participants and all were presented and discussed in 
an easy, understandable manner.  

 All the training sessions were interactive and the questions and difficulties were solved during 
practice session. 

 All the partcipants were evaluated to know their enhanced capacity through a subject 
oriented test. 
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QGIS Interface  
To launch QGIS, click: Start -> All Programs -> QGIS -> QGIS Desktop. QGIS normally adds the version 

number after “QGIS”, which is currently 2.16.2. The main windows of QGIS can be divided into three 

regions shown in Figure 1. 

 

Figure 1. The Main Window of QGIS showing Region 

Frequently-used File Formats in QGIS: 

 

 Feature Data: Feature data are usually organized as points, lines, and polygons in vector 
format.



 Shapefile: The most commonly used geospatial data format. Although it appears to be 
one file inArcMap, shapefile includes multiple files with the same file name, but 
different extensions. *.shp, *,dbf, and *.shx are must-have.



 Personal Geodatabase: These files are based on Microsoft Access (*.mdb). From 
userperspective, all kinds of geodatabase are the same, which include multiple 
layers (different geospatial data) in one geodatabase.



 MapInfo files: The following three are legendary geospatial file formats. MapInfo 
is the firstdesktop GIS software for Windows. Its files (*.tab) are widely used.


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 ArcInfo: ArcInfo is the previous generation of ArcGIS. Its file (*.e00) are supported 
in QGIS aswell.



 Google Earth: *.kml and *.kmz (zipped KML) are Google Earth file formats, which are 
popular inLocation-Based Service now. Many websites support kml and kmz files.



 GML and GeoJSON: Open source geospatial data standard, which is also popular 
in onlineapplications.



 GPS: The track of GPS records can be imported into QGIS as *.gpx files. This 
function is veryuseful in surveying.



 CSV: *.csv files stands for comma separated value, which can be regarded as a 
legendaryspreadsheet file format.



 Raster Data: Raster data uses grid to represent a region with values as a “field”. 
Imagesexplicitly have the parameter of resolution. Typical raster data is:



 GeoTIFF: They have the file extension of *.tif. The key difference between normal TIFF 
file andGeoTIFF is that GeoTIFF has projection information. Hence, normal TIFF files 
cannot be correctly added to the desired location.



 GeoJPEG: Similar to GeoTIFF, but they have *.jpg extension.



 Usage: Raster data can be air photos, satellite images, elevation data (DEM). But 
raster datatends to be huge and slow to load.

 

3. Loading and Integrating Different Formats of data with QGIS 

3.1 GPS to QGIS 

There are dozens of different file formats for storing GPS data. The format that QGIS uses is 

called GPX (GPS eXchange format), which is a standard interchange format that can contain 

any number of waypoints, routes and tracks in the same file. 

To load a GPX file you first need to load the plugin. Plugins‣  Plugin Manager... opens the 

Plugin 

Manager Dialog. Activate the  GPS Tools checkbox. When this plugin is loaded two 

buttons with asmall handheld GPS device will show up in the toolbar: 
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GPS Tools 
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For working with GPS data we provide an example GPX file using which the following 

steps have to be performed- 

1. Select Vector‣GPS‣GPS Tools or click the  GPS Tools icon in the toolbar and open 

theLoadGPX file tab (seefigure_GPS_1). 
2. Browse to the folder qgis_sample_data/gps/, select the GPX file 

national_monuments.gpxand click [Open]. 
 

 

 

 

 

 

 

 

 

 

 

Figure 2.:The GPS Tools dialog window 

 

Use the [Browse...] button to select the GPX file, then use the checkboxes to select the feature types 

you want to load from that GPX file. Each feature type will be loaded in a separate layer when you 

click [OK]. The file national_monuments.gpx only includes waypoints. 

Note 

GPS units allow to store data in different coordinate systems. When downloading a GPX file (from your 

GPS unit or a web site) and then loading it in QGIS, be sure that the data stored in the GPX file uses 

WGS84 (latitude/longitude). QGIS expects this and it is the official GPX specification. 

Importing GPS data 

To import GPS data from a file that is not a GPX file, you use the tool Import other file in the GPS Tools 

dialog. Here you select the file that you want to import (and the file type), which feature type you want 

to import from it, where you want to store the converted GPX file and what the name of the new layer 

should be. Note that not all GPS data formats will support all three feature types, so for many formats 

you will only be able to choose between one or two types. 

 

http://docs.qgis.org/2.0/en/docs/user_manual/working_with_gps/plugins_gps.html#figure-gps-1
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3.2 Loading Vector data (shapefile) 

Click the Add Vector Layer  button to add geospatial data (Figure 2), which opens a window (Figure 

3) 

 

 

 

 

                                Add data 

 

 

 

 

 

 

 

Figure 3. A. The Main Window : Add Vector Layer button  Figure 3.B. The Pop-up Window to "Add Vector Layer" 

Then you can browse to the file you want to work with by clicking the Browse button just like any other 

file explorer dialogs in Windows. You can open multiple files at one time by holding the Ctrl or Shift 

button when you are clicking the mouse button to make selections. The by-default file filter is *.shp file 

(Figure 4). But there are many other choices, such as *.kml (Google Earth) and *.csv, much broader than 

ArcGIS.  

 

 

 

 

 

 

 

 

 

 

Figure 4. The File Open Dialog with File Filters 



11 
 

For example, you can browse Khulna_Div.shp file from pov_khl folder that was provided in Practice 

Data folder as your sample dataset. 

3.3 Load Google Maps ,Bing Maps and Openstreet Maps: 

QGIS provides the flexibility of using Google (or Yahoo) Satellite images or Bing aerial images as a 
background layer in your map. To do so, follow the steps below: 

1. Install the OpenLayers Plugin into QGIS: 

a. Go to Plugins -> Manage and Install Plugins, which leads to a dialog. 

b. Type 'Openlayers Plugin' in the search box 

c. Click on 'Install plugin' and the 'Openlayers Plugin' will be  

installed in your QGIS. 

2. Add Google Satellite map as Background layer: 
 

 

 

 

 

 

 

 

 

 

Go to the menu Web ->Openlayers plugin ->Add Google Satellite Map. 

 

 

 

 

 

 

 

 
3. Add Bing Aerial Map as Background layer: 
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Go to the menu Web ->Openlayers plugin -> Bing maps-> Bing aerial. 

4. Add Openstreet  Map as Background layer: 

Go to the menu Web ->Openlayers plugin ->OpenstreetMap->OpenStreetMap 

 
 

3.4  Loading CSV File from excel and Modification of 

attribute table 

A CSV is a comma separated values file, which allows data to be saved in a table structured format. CSV 

can be converted from an excel file and it  is more necessary when we are using the date in QGIS. QGIS 

directly supports CSV file rather than an excel file. So, if you have an excel data to join, you must convert 

it into CSV file and then load into QGIS. 

Conversion to CSV 

 Open the Excel file in Microsoft Office Excel and save it as a anew file 

 Click on File>Save As> Select CSV as Save as type> Save 
 

 

Figure 5. Pop-up window of Excel Save as type option 
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3.5 Loading CSV in QGIS 

Now, the excel file has been converted into a CSV file and will be loaded into QGIS. Click on Layer on 

menubar>Add Layer>Add Delimited Text Layer. The point to be noted that there are two types of tabular 

data: one contains geographic data (x, y coordinates) and another contains descriptive data having in 

details information. 

 

3.6 Creating KML layer in Google Map and Loading in 

QGIS: 

Google map or Google Earth makes use of KML or keyhole markup language, to display features, which 

actually stores geographic features in Vector format. You can create KML file from Google map for 

mapping and displaying the same by again uploading the same KML file on Google map or created KML 

file converted from Shapefile. Before creating KML file on Google map, you should have an Google 

account and should be logged in with that. So that once KML file created, you would be able to see it in 

My Places of Google map after wards. You can also look link for how to create KML file from Google earth. 

Steps are following: 

 Open Google map and sign in with all in one Google account. 

 Click on Menu ( Left corner of search option)>Your Places>Maps >Create Map ( At the Bottom) 

( A new window will open) 

 Click on Add layer ( A new untitled layer will open)>Layer Option ( At the right corner with 

three dots) . You can rename , delete or see the table of the layer. 

 
 

Figure 6 Layer OptionFigure 6: The Drawing Options 
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 In the map window  there are some drawing options. If you keep you cursor on the options, it 

will show you the name. Add marker is used only to put any points on map and Add line or 

shape is used for drawing any polygon or line .Before drawing , search your area in search 

options. 

Note that while you are drawing any polygon, it will be a confined area  and the starting and ending 

point will be the same. While drawing any feature, please complete your desired drawing  with double 

click at ending point. 

 When you have completed drawing any feature( point, line or polygon), a pop-up window will 

open to write the name and description about it and you will also find the edit and style options 

below he pop-up window. 

 

Figure 7.  The pop-up window for feature details 

 If you have completed drawing all the features under a layer , now it’s time to export the layer 

as KML. From Untitled map at left top corner of the page, there are three dots as representing 

different options. Click on it and select Export To KML. A pop-up window will open and select 

the desired layer and download it. The layer has been saved as KML file . 

 

Figure 8. Pop-up window of Export to KML 

 Open QGIS desktop > Add Vector layer > Browse kml layer>Right click  on kml layer >save it as  

a shapefile from Save as option 
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Figure 9. A pop-up window of save vector layer as option 

 

Figure 10.  Pop-up window showing to Layer option 

In case of geographic data, the file format will be CSV and geometry definition will be Point coordinates 

which will create a point layer in layer panel. Then you must save your layer as shapefile from Save as 

option by right clicking on the layer. 
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Figure 11. CSV browsing in case of geographic data 

In case of descriptive data, file format will remain same as CSV but there be NO geometry in Geometry 

definition option but one thing to note down that this time data won’t create any shapefile unlike 

geographic data as it is a descriptive file having no geometric points. 
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Figure 12. CSV browsing in case of descriptive data 

3.7 Joining attribute table 

If we have both geographic and descriptive data both for any specific location, we will generate a point 

shapefile from GPS data and there must be some common attributes like Serial number in both file on 

basis we can join both data. As the point layer is a shapefile , it’s attribute table will expand after joining 

the description of the points. Besides, we can also join any tabular data with any shapefile with a 

condition of common coloumns in both .Steps are following: 

 Right click on shapefile>Properties>Joins 

 Click on plus sign (+)  at the left bottom to add the the table 

 Join layer will be the tabular descriptive data 

 Join Field and  Target field are the ncommon attributes we need to select 

 Click on Choose which fields are joined and  selecte the attributes according to 

requirements 

 Then Ok> in next window Apply>Ok. 
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Now Open the attribute table of shapefile by right clicking and you will see the added columnsin layer. 

But now,if we remove this layer now and then browse again you won’t find the added field anymore as 

it wasn’t saved when u added. So, whenever you are joining any data , just save it as another shapefile 

from Save as  option and after that as much as you remove , you will find the the data u added as same. 

Figure 13. Pop-up window showing the join options 

 

3.8 Editing in attribute table  

As data input is very very manual, so it’s not ever surprising if we find any typing mistake in attribute 

table . Then we need to make it correct or change anywhere if needed to use a correct data and from this 

point of view ,editing is one of the most important part in attribute table modification. To edit , open the 

attribute table of the layer  and click on the very first option , Toggle editing modein toolbar.Now the 

editing mode is active and you can delete or change any text or number or calculate any field or create 

any new field or add any new feature . 
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3.9 Extracting selected attributes from table 

While we are having  huge dataset like any divisional map or any soil/forest  map for a large area or any 

distric map etc. having in detailed information and we want to work on a specific area or any specific 

attributes, we need to extract the data from the large dataset . The selection depends on the attributes 

we want to make an anlysis over. 

 Open the attribute  table  and click on Select/ filter feature using from( The view will be 

changed) 

 Then Coloumn preview> select the coloumn in which desired attributes are existing 

 Click on the attributes by pressing shift button you want to extract at left side ( The selected 

attributes will also be selected in map canvas) 

 Now right click on layer and save it as a new shapefile from Save as option. Now the new 

shapefile contains the selected attributes only. 

 

 
Figure. Pop-up window showing the select by attributes option 
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3.10 Extracting attribute table as an excel file 

 Install the XY Tools into QGIS: 

 Go to Plugins -> Manage and Install Plugins, which leads to a dialog. 

 Typein the search box 

 Click on 'Install plugin' and the XyToolswill be installed in your QGIS 

 Select the layer in layer panel first and then click on Vector>XY Tools>Save Attribute table as an 

excel file 

 Select the required fields and click on ok. 

 

 

Figure 14. XY Tools option                                                                         Figure 15. save as Excel option 

 

3.11 Loading GPX File from excel and Using field calculator 

GPX stands for GPS exchange Format that c 

 Click on ADD Vector layer > Browse GPX file format using data type keeping GPX 

 Select  all the Layer 
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Figure 16. GPX Data Format 

 Open Attribute table to check the data it contains. Waypoints , trackpoints have poins in 

shapefile. Now we will calculate X and Y coordinates using Field calculator. 

 

 

Figure 17.  Pop-up window of Vector layer to add 

 

 The point layer we want to add X and Y coordinates , need to open it’s attribute table 

 Click on Open fIeld calculator 
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 Type field name , Field type, field length, precission and expression and Click on ok 

 

Note that we are calculating latitude select $y and double click on it to activate and while calculating 

longitude select $X and double click on it. The field type will be decimel degree as it is coordinate. 

 

Figure 18.Pop-up window of Field calculator 
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5. Map Attributes: Labels and Symbology 

5.1 Key Options of Geospatial Data Representations 

Main options of changing geospatial data representations include layer order, layer transparency, 

symbology, label, and annotation. Apart from the first one (layer order) and last one (annotations), all 

the rest are located in the pop-up window when you right-click the layer you want to modify and select 

property .They are under either the style or labels tab. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 19.The Pop-up Window of aLayer's Property                                Figure28 : The Property Window 

All options will be introduced as subsections in the following 

5.2 Layer Order and Transparency 

QGIS displays geospatial data according to the order in the table of contents: the bottom layer will 

be drawn on the screen first and covered by upper layer. Hence, the layer on the top in the table of 

contents will be displayed as the top layer in the map. Unlike ArcMap, QGIS will not order layers 

automatically. 

When a feature layer (point, line or polygon) is put under a polygon-feature layer, the feature one is 

covered and invisible. You can change layer visibility by switching the checkboxes left to the layer 

name in table of contents (Figure). And the display order can be changed by simply dragging the layer 

toward or away from the top 
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Drag to 

Change Order 

 

 

 

 

 

 

 

 

Figure 20. Layer Visibility and Order Control 

When a polygon layer, such as buildings or parcels, is added over an image, the content on image under 

the building is often invisible. But sometimes users like to only show the parcel’s boundary and keep 

the image displayed. In this case, layer transparency and hollow symbology can help. To do so, right-

click on the polygon layer and select Properties first (Figure 8). Then switch to the tab Symbology and 

click on the symbol itself (Figure :Properties of style).  

 

 

 

 

 

 

 

 

 

 

                                                               Figure 21. Properties of Style 

Visibility Checkbox 
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5.3 Symbology and Label 

Symbology or Style is critical in making maps, which are classified into four Legend type in QGIS (on the 

top of Figure). Due to its complexity, these four categories and their normal usages will be briefly 

introduced in the note region with further reading. We will only focus on symbol customization and 

classification symbols, which are mostly used. Unlike ArcMap, QGIS does not hold a large library of 

professional symbols. In fact, only point-feature layers can have different symbols (Figure), while line 

and polygon layers can only change line and fill options. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 22.The Symbology or Style Customization Window 

We can also categorized data depending on the categories in the Style option of Properties of a 
selected feature. 

 

 

 

 

 

 

 

 

Figure 23. Categorization in Style option 
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Note that you can still customize individual symbols for each category (size, shape, etc) by double clicking the corresponding class 
on either the left pane or the line in Style window (Figure). The labels are an important feature of a map. By marking some 
property up on the map, for instance the name of the marked location, labels can make your map more useful, informative, and 
visually appealing. To add labels to your map, right-click on the layer that you want to add marks on and select Properties (Figure 
8). Then follow the steps below: 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 24.Example of Style 

 

1. Select the Labels tab and check on (off by default) “Display labels”. 

2. Choose the attribute you want to display on the map in the dropbox of Field Containing label  

3. Change Font, so that it is clearly shown on the map. 

4. You can click on the Apply button to see the effect until it is satisfactory. Then click OK to save your 

setting and exit. 

5. (Optional) If you think the added labels are not distinct on the map background, you can make a 

buffer background around the texts. Please scroll down and check Buffer labels, which has the same 

effect of “mask” in ArcMap 

 

Example: Graduated Map- To present variation of data within a region a graduated map can 

bedeveloped by right clicking on the layer and select Properties-> Style-> then select the options as 

the picture below. The class interval and the class breaks can be customized by clicking on them. 
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Figure 25. Selecting Graduated properties 

 

Figure 26. Graduated Map 
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Figure 27. Labels setting window 

 

 

 

 

 

 

 

 

 

 

 

               
Figure 28. Graduated Map with labels 
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6.OpenStreet Map 

6.1 STARTING THE iD EDITOR 

 To use iD you will need to be connected to the internet. 
 Open your internet browser, and go to the OpenStreetMap website at 

http://www.openstreetmap.org. 
 Login using your OpenStreetMap account 
 Pan and zoom the map to the area that you want to edit. 
 Click on the small arrow next to Edit. Then click Edit with ID (in-browser editor). 

 

iD Editor User Interface 

 

http://www.openstreetmap.org/
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1. Feature Panel: This panel shows tags from the object selected on the map. You can add 
or edit tags from this panel. 

2. Tools: This panel shows basic editing tools:  

o Draw point  

o Draw line  

o Draw shape (polygon)  

o Undo  

o Redo  

o Save changes  
3. Map panel: This panel show various configuration functions:  

o Zoom In  

o Zoom Out  

o Go to your location  

o Configure background layer  

o Open Help Menu  
4. Information panel: This panel shows various information, such as which users have 

contributed to the area. 

6.2 CONFIGURING THE BACKGROUND LAYER 

Before you start editing, you can change the background layer. 

 Click the Background settings button. 

 You will see a panel like this: 
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 You can change the brightness level by clicking one of these boxes: 

 There are 3 different brightness levels - 100%, 50%, and 0%. Click all of 
them to see the difference. 

 You also can change the background layer based on your desired tile provider (the 
default is Bing Aerial Imagery). Try the various options available from this list. 

 You can add your own map tiles by clicking on Custom. 
 For example, if you want to add a Field Paper, click Custom and enter your FieldPaper 

snapshot URL, which will be something like this: 

http://fieldpapers.org/snapshot.php?id=cqhmf2v9#18/37.80593/-122.22715 

 

http://fieldpapers.org/snapshot.php?id=cqhmf2v9#18/37.80593/-122.22715
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 You also can display GPS tracks from your computer (GPX format). It is very easy - just 
drag the GPX file into ID editor. 

 If there is imagery offset, you can correct the imagery offset by clicking Fix 
Misalignment. 

 

 Click the navigation buttons to move the imagery. Click the reset button to return to the 

default position.  

 

6.3 HOW TO UPLOAD GPS DATA ? 

 
1. Go to the main OSM page. 
2. Login (remember you need an OSM account by signing up here). 

3. Click “GPS traces” along the top. 

4. Click on "See just your traces, or upload a trace". 

5. In the 3 boxes at the top do the following: 

1. Find and select the file you wish to upload (it should be .gpxformat) 

2. Name the file. 

3. Add helpful tags that can be used to find it such as “London UK” (each word is a tag in 

itself, so Isle of Wight should be "IOW" or "Isle-of-wight"). 

6. If you would like your data to be available to others (encouraged) tick the "Public?" box. 

7. Click "Upload". 

8. The data will now take a short while to be included into OSM. However, as soon as you've 

uploaded it, you can immediately use it. 

 

6.4 BASIC EDITING WITH iD 

Before we start practicing with iD, pan and zoom to a location that you familiar with. You can 
pan by holding the left mouse button and dragging the map to your desired area. 

Adding Points 
 To add a new point, click on the Point button. 
 Your mouse cursor will change into plus (+) sign. Now, click on a position that you know 

to mark a location. For example, if you know that there is a hospital in your area, click 
on the hospital building. 

http://learnosm.org/en/editing/aerial-imagery
http://www.openstreetmap.org/
http://www.openstreetmap.org/create-account.html
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 Notice that a new point is added. At the same time, the left panel will change to show a 
form where you can select attributes for the object. Click Hospital to tag the point as a 
hospital. 
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 You can use the forms to fill detail information about your point. You can fill hospital 
name, address, and/or other additional information. Note that each feature will have 
different form, depending on what tag you choose from the feature panel. 

 If you make a mistake, such as a wrong location, you can drag your point to a new 
location by holding the left mouse button on your point. Or, if you want to delete your 
point click the left mouse button on the point and then click the button which looks like 
a trashcan. 

A “point” created in the iD editor is actually a standalone “node” with a set of “tags” 
on it. 

Drawing Lines 

 To add a new line, click on the Line button. 

 Your mouse cursor will change into plus (+) sign. Find a road that hasn’t been drawn on 
the map and trace it. Click once on a point where the road segment begins, move your 
mouse, and click to add additional points. Double-click to end the drawing process. 
Notice the panel on the left. 

 

 Just as with a point, select the appropriate tags for your line. 
 You can drag points from the line by clicking your left mouse button on a point and 

dragging it. 
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 You also can move the whole line by selecting it, and choosing the Move tool. 
Then drag the line to a new position. 

 When you click your left mouse button on a point from the line, you will see 
these tools: 

o Delete point from line  

o Disconnect point from line  

o Split a line into two line from the point you’ve selected  
 When you click your left mouse button on a line, you will see these tools: 

o Delete line  

o Create a circle from a line (only active if the line is closed)  

o Move line  

o Form a square shape from a line (only active if the line is closed)  

o Reverse line direction  

A “line” created in the iD editor is actually a “way” with “tags” on it. 

Drawing Shapes (Polygons) 

 To add a new shape, click on the Area button. 

 Your mouse cursor will change into plus (+) sign. Try to trace a building using the 
imagery as a guide. 

 You will notice that the color of your shape will change depending on the attributes that 
you assign to it. 
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 The tools that are available when you select a shape are similar to those when you click 
on a line. 

A “polygon” in the iD editor is actually a “closed way” with tags on it. 

SAVING YOUR CHANGES 

 When (and if) you want to save your edits to OpenStreetMap, click the Save button. The 
panel on the left will show the upload panel. 
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 Enter a comment about your edits and click Save. 

ADDITIONAL INFORMATION AND CUSTOM TAGS 

 When you are editing and object, you will see a strip of icons at the bottom of the 
attribute panel. You can add additional information by clicking these icons: 

o Add elevation  

o Add notes  

o Add contacts / phone number  

o Add source tag  

o Add website  

o Add accessibility information  

o Add Wikipedia link  
 Or, you can add custom tags by clicking All tags. 
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 This will show all the tags attached to the feature. 

 

 Click the plus sign (+) to add keys and values or click the trash icon to delete tags. 
 

ADDING TAGS 
In the previous section you learned about OpenStreetMap's geo elements. It is time to learn a little about 
OpenStreetMap's tagging scheme. The basic tagging scheme can be found in Tagging. The tagging page 
links to the Map Features page which lists most of the keys accepted by the OSM community. Many of 
the examples on the Map Features page, particularly those regarding roads, are specific to the U.K. Users 
in other countries will want to look at Tagging for guidance in applying the tagging scheme to their 
country. 
 

Types Of Geo objects 
OpenStreetMap's Tagging Scheme has 3 data types that may be tagged: 

 
Node: Just a node/point used to mark a particular point on the map. For example: 

 A town may be marked using a node tagged with place=town. 

 A theatre may be marked using a node tagged with amenity=theatre. 
 
Linear: A way used to mark a particular linear item on the map. For example: 

 A motorway may be marked using a way tagged with highway=motorway. 

 A river may be marked using a way tagged with waterway=river. 
 
Area: A closed way to mark a particular area on the map. For example: 

 A lake may be marked using an area tagged with the natural=water. 

 A town may be marked using an area tagged as place=town. 

 

 

 

 

 

http://wiki.openstreetmap.org/wiki/Beginners_Guide_1.3
http://wiki.openstreetmap.org/wiki/Tagging
http://wiki.openstreetmap.org/wiki/Map_Features
http://wiki.openstreetmap.org/wiki/Map_Features
http://wiki.openstreetmap.org/wiki/Tagging
http://wiki.openstreetmap.org/wiki/Tagging
http://wiki.openstreetmap.org/wiki/Key:place
http://wiki.openstreetmap.org/wiki/Key:place
http://wiki.openstreetmap.org/wiki/Tag:place%3Dtown
http://wiki.openstreetmap.org/wiki/Proposed_features/Theatre
http://wiki.openstreetmap.org/wiki/Key:amenity
http://wiki.openstreetmap.org/wiki/Tag:amenity%3Dtheatre
http://wiki.openstreetmap.org/wiki/Key:highway
http://wiki.openstreetmap.org/wiki/Key:highway
http://wiki.openstreetmap.org/wiki/Tag:highway%3Dmotorway
http://wiki.openstreetmap.org/wiki/Key:waterway
http://wiki.openstreetmap.org/wiki/Key:waterway
http://wiki.openstreetmap.org/wiki/Tag:waterway%3Driver
http://wiki.openstreetmap.org/wiki/Key:natural
http://wiki.openstreetmap.org/wiki/Tag:natural%3Dwater
http://wiki.openstreetmap.org/wiki/Key:place
http://wiki.openstreetmap.org/wiki/Key:place
http://wiki.openstreetmap.org/wiki/Tag:place%3Dtown
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